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6. Transformations 
Using reflections, rotations, and dilations 

7. JavaSketchpad Documents 
8. Articles about SketchPad 

 
 
 
 
 

                                                 
  Copyright  2001-2004 Stephen D Comer 

mailto:Steve.comer@citadel.edu


 2 

Introduction 
 
Starting the program 
Go to CitNov1 Programs located in the CitNet folder on the desktop. Scroll through the list of 
programs to locate Geometer’s SketchPad.  Double click it. 
 
Work area 
The SketchPad window can be resized to suit your 
convenience. Each sketch has its own window 
inside the main SketchPad window. These can also 
be resized and several sketches can be active at the 
same time. See a Window at the right. 
 
Menu items.  They are File, Edit, Display, 
Construct, Transform Measure, Graph, Window, 
and Help listed across the top. Their meaning will 
change depending on the objects selected. Check each one to get an idea of the options 
available.  
 
Tools (on left side): 
The six basic tools do the following: 

   Pointer: use to select and move objects 
    Dot: use to create points 

Circle: hold the left mouse button and drag to create a circle 
    Segment: hold the left mouse button and drag to create a segment (or line or ray)  

  Text Tool: selecting this allows labels and text boxes to be created. The cursor 
 changes to a finger. 
  Solid Arrow: this tool allows you to create and use custom tools. 
 
Note: pressing the left mouse button while over the segment tool allows it to be changed to a 
line or ray tool. 
 
Next two simple figures will be created to illustrate the use of various tools and menu items. 
 
Example 1. 
Start with a clean sketch. This example constructs a triangle, labels the parts and adds a text 
box. The resulting sketch is shown below. 
1. After selecting the dot tool click the work area in 3 places creating 3 points. 
2. Select all three points. [To do this use the arrow tool.  Hold the shift key while clicking 

each point.  While it does not matter in this case, sometimes the order in which the points 
are selected are important; for example when selecting points to form an angle.] 

3. With the points selected go to the Construct menu and select Segments.  The three points 
should now be joined to form a triangle. 

4. Click somewhere to deselect the sides of the triangle. With the arrow tool selected hold the 
mouse on different parts of the triangle and move.  

5. Labels. Select the Text Tool.  The cursor will change to a finger. Click each vertex and 
side of the triangle to reveal the default label. Clicking an object a second time will hide the 
label.  To change the name of a label, double click the label with the finger.  A dialog box 
will appear in which the name can be changed. 
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6. Text boxes. With the Text Tool selected move the mouse (finger) to an area where the text 
is to be placed. Double click the left mouse button to create a box for text to be entered.  
Add to your sketch a box that says:  This is my first sketch.  To reposition or resize the text 
box use the arrow tool. Note: when a text box is open for editing an array of font types and 
symbols is available at the bottom of the SketchPad window. 

7. To delete an object or group of objects, select them and press the delete key.  Be careful 
with delete.  If you delete an object, its “children” (objects whose construction depends on 
them) will also go. If you make a mistake remember Undo is in the Edit menu.  Instead of 
deleting an object it may be better to just hide it. This is illustrated in the next example. 

 
Example 2. 
Start with a clean work area. In this example you will construct a line segment congruent to 
and perpendicular to a given line segment. 
1. Select the Segment tool and draw a short line segment near the center of the work area.  

Label the endpoints A and B. 
2. Select the point A and the segment (see step 2 in Example 1 if you forgot how).  From the 

Construct menu choose Perpendicular line. This produces a line through A perpendicular 
to the segment. 

3. Now select A and the segment again.  This time choose Circle by Center and Radius from 
the Construct menu. This produces a circle with center A and radius AB. 

4. Select the circle and the line.  From the Construct menu choose Point at Intersection.  The 
two points where the circle and line intersect are created. 

5. Select one of the points created in Step 4 (call it C) and select A.  Create the line segment 
AC using the Construct menu.  You won’t be able to see it because the original line 
perpendicular to AB covers the segment. 

 

6. Clean up time! Select the line created in Step 2 and the circle created in Step 3. From the 
Display menu choose Hide Objects.  Oh, the extra point created in Step 4 is still around.  
Hide it too. 

 
Here is the result after clean up. 

 

A

B

C
This is  my first sketch.

A B

C

A B

C
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Now we have a segment AC congruent to AB that is perpendicular to AB.  Select various parts 
and move.  Notice that moving an initial point (A or B) changes the size or position, but 
moving a child (C or a segment AB or AC) moves the whole configuration. 
 
Exercise: Continue the above construction to form a square that always retains its shape when 
moved. 
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Animation and Tracing Techniques 
 
We need something to work with.  Construct a circle, an arbitrary 
point A on the circle object, and a point P interior to the circle. 
Then construct a circle by center (A) and point (P) as in the picture. 
 
 
Constructing Interiors 
First select the object, for example a circle or a series of vertices of a polygon. Then go to the 
Construct menu and select Circle Interior (or Polygon Interior). 
 
Under the Display menu choose Color to set a color for the interior if you do not like the 
default choice. 
 
Here is the result. 
 
 
Animation 
We want to animate the small circle with center A by moving A around the larger circle. First 
select the object(s) to animate: in this case the point A. It is constrained by the large circle. 
Having made these selections go to Display>Animate Point.  The following Motion 
Controller box appears. 
 
 
 
 
 
 
You can stop, start, pause, reverse direction, and change speed of the animation with this box. 
Closing the Motion Controller hides it without stopping the animation. To stop the animation 
without the Motion Controller select Display>Stop Animation. 
 
Tracing  
Animating an object is interesting but it would be nice to see the locus of points being 
generated. To do this you must turn on "Trace" before starting the animation.  To turn the 
"Trace" feature on, select the object you want to trace.  Then go to Display>Trace. That's it.  
Now when an animation (or any other movement) is performed the locus of the object will 
remain on the screen until the screen is clicked.  Below is the result of tracing the circle interior 
when A animates around the circle. 

 

A
P

A
P
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Custom Tools  
 
When investigating problems in SketchPad many constructions are performed over and over.  
GSP 4 allows Custom Tools (called Scripts in previous editions) to be created to eliminate the 
repetitive constructions. A Custom Tool can be played whenever that construction is needed.  
Below we see how to create a Custom Tool that is associated with a document. Also, we will 
indicate the process for placing a Custom Tool in a menu so that it is available for any 
document.  More information can be found by going to the GSP Help item by searching for 
Custom Tools. 
 
Creating a Custom Tool  
We will build a tool to construct the centroid (intersections of the medians) of a triangle.  The 
strategy is to create a Tool by example.  From the File menu select New Sketch if you do not 
have a clean document.  
 
Start by constructing the centroid of a triangle. [That is creat 
three points (the triangle vertices), construct the segments 
connecting the vertices, construct the midpoints of each side, 
construct the segment from each midpoint to the opposite 
vertex, and finally construct the point of intersection of two of 
the medians (the third will fall on the intersection).]   
 
Choose Save As from the File menu and save this sketch as 
centroid.gsp.   
 
 
 
 
So far there has been nothing different from what we’ve done before.  When we create a Tool 
we must specify the Given and the Results.  For our Tool the Given will be the vertices of the 
triangle and the Results will be the sides of the triangle and the Centroid point. Click off the 
sketch to make sure nothing is selected then, in order, select the three vertices, the three sides 
and the Centroid point.  Now click the left mouse button on the little arrow at the bottom right 
of the Custom Tool icon   .  This brings up the Custom Tool menu 
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Select Create New Tool and fill in the name “Centroid” and 
click “OK”. SAVE the sketch.  
 
Now, the Custom Tool menu has another item: Centroid. 
Before we use this Tool click on the option to Show Script 
View.  You should see three initial vertices identified as Given 
and the Steps for the construction of the Centroid point.  
 
Applying a Custom Tool. 
Minimize the sketch used to create the Centroid Tool and open a new sketch.  Create a triangle, 
create the midpoints of each side, and then join each of the three midpoints with segments.  
This should divide the original triangle into 4 (congruent) triangles. Now, we want to apply the 
Custom Centroid Tool to each of the 4 smaller triangles.  
 
To do this, select Centroid from the Custom Tool menu.  Notice the cursor changes to an arrow 
and has a point at the head (because the first Given is Point A).  Also, notice the message at the 
bottom Geometer’s Sketchpad that says: “Match Point A”.  Click one of the vertices of the 
triangle. Now, the message says: “Match Point B”.  Click on another vertex.  The message say, 
“Match Point C”, so do it. Notice that a new point – the centroid of the triangle whose three 
vertices you selected has now been created. 
 
On your own  
use the Centroid Tool to (1) find the centroid of each of the smaller triangles, (2) find the 
centroid of the large triangle, and (3) find the centroid of the triangle whose vertices are the 
centroids of the 3 “outside” triangles.  How does this point relate to the others? 
 
The Custom Tool folder 
 
When we created the Centroid Tool above it appeared in the Custom Tool menu in the “This 
Document” section. To use such a Tool the document must be open – although not the current 
sketch. After having created a lot of Tools this can create quite a management problem.  By 
placing a Custom Tool in a special folder, called the Tool Folder, the tool becomes available 
whenever Sketchpad is open without having to open the sketch used to create it.   
 
The Tool Folder is located in the same folder that contains the GSP executable. It should have 
been created when the program was installed; if not, create it and be sure to name it Tool 
Folder. 
 
Here is the process for adding frequently used tools to the Tool Folder.  
(1) Create or copy the Custom Tools you want to put together into a new document. 
(2) Choose Save As from the File menu, navigate to the Tool Folder, and save with an 
identifying name. 
(3) The next time you start Sketchpad the name you specified will appear in the Custom Tools 
menu under Tool Folder and can be used. 
 
Document Pages 
Another way to organize sketches is to group them in pages. When a document has more than 
one page a page tab appears at the bottom of the document window.  To add pages or to name a 
page, select Tool Options from the Custom Tool menu.  Select View: Pages. Here you can 
hide or show the page tabs, name pages, add pages of remove page. 
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Measuring and Calculating 
 
In some geometry problems it is necessary to measure angles or lengths and to perform 
calculations with the results.  Tools for doing this (and more) are found in the Measure menu.  
The following examples should get you started. 
 
The examples will use a triangle with vertices A, B, C.  Start by 
constructing one. 
 
Measuring angles 
Select (using the shift-click method) vertices A, B, and C in order. The select Measure > 
Angle. The value m∠ ABC should be placed on the sketchpad. You can position the equation 
wherever you wish by clicking it and dragging it to another location.  Measure ∠ BCA and 
∠ CAB in the same way. 
 
 
 
 
 
 
Calculating 
Ok, let’s find the sum of the angles.  Make sure nothing is selected in the sketch.  Go to 
Calculate in the Measure menu.  Clicking this brings up a calculator like screen with a black 
square in the center.  Click the m∠ ABC equation.  This moves m∠ ABC to the calculation 
window.  Now, click “+” on the calculator keypad, then the m∠ BCA equation, the “+” again, 
and finally the m∠ CAB equation.   Clicking “OK” places the calculation on the sketchpad.  
Notice that resizing the triangle causes the angle measures to change, but the sum of the angle 
measures stays the same.  Hmmm! 
 
Calculating lengths and distances 
To calculate the length of the segment AB select the segment, then select Length from the 
Measure menu.  To measure the distance from A to B select the two points A and B, then 
choose the Distance option from the Measure menu.  What’s the difference?   
 
For practice calculate the lengths of the segments AC and BC.  Then go to the Calculate option 
and compute AB2+AC2 and BC2.  Move the vertices of the triangle until AB2+AC2 = BC2.  
What’s the key?   
 
Other calculations 
Area and perimeter:  Before using these an interior needs to be selected.  To form the interior 
of a polygon select the vertices in order then go to Interior under the Construct menu.   
Slope:  Select a segment or line in order to use this option of the Measure menu. 
Equation:  Select a line before using this option.  Before using either slope or equation it 
makes sense to select Show Axes or Show Grid from the Graph menu. This way you see the 
coordinate system.  From the Graph > Grid Form menu you can also select either Square, 
Rectangular, or Polar grid.  

A

B

C

A

B
C

m ABC = 110°

m BCA = 33°

m CAB = 37°
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Hyperbolic Geometry Models 
 
Models for hyperbolic geometry can be constructed in the Euclidean plane. Two such models 
are the Poincare disk model and half-plane model. Tools have been written for the Geometer’s 
Sketchpad to help you work with these models. The scripts for the Poincare Disk model can be 
downloaded from forum.swarthmore.edu/sketchpad/gsp.gallery/poincare/poincare.html 
and the scripts for the half-plane model can be downloaded from 
www.keypress.com/Sketchpad/misc/sibley/sibley.htm. Once the scripts have been 
downloaded they can be added as Custom Tools as in Section 3. These notes will only illustrate 
the use of tools created for the Poincare Disk model. 
  
The basic model 
Start with a blank sketch. Hold the mouse on the little arrow in the lower right-hand corner of 
the Custom Tool icon and select Poincare Disk, then Poincare disk model from the Tool 
Folder. (It is useful to turn-on Show Script View from the Custom Tool menu to see the order 
of the “givens” in the constructions.) To construct the basic Poincare disk (P-disk) model first 
click a point to fixes the center of the disk, then a second point to determine the radius. The 
labels can be changed as in the following example.  
 
 
 
 
  
 
 
 
 
 
Your labels can be more concise, but it is important to identify the P-Disk Center and the P-
Disk Radius.  You will need these points to align other constructions to the model. 
 
Using P-disk model tools 
Why do we need the new tools and what do they do?  To see the difference note that if you 
select two points in the P-Disk and draw a line through them using the standard GSP line tool, 
you get an Euclidean line, not the “P-line”.  To obtain the hyperbolic line, that is, an arc of a 
circle orthogonal to the circumference of the disk, additional constructions are needed.  That’s 
what the P-tools provide. Here is a list of the tools with a brief description of what each does. 
 

Line Constructs a Poincare line through two points 
Segment Constructs a P-segment between two points 
Angle Measures hyperbolic angle with second point as vertex 
distance 2 points Measures the (hyperbolic) distance between two points 
perp bisector of segment Constructs perpendicular bisector of P-segment 
Pert Pt to line Constructs perpendicular from point to P-line 
angle bisector Constructs bisector of angle determined by 3 points 
Circle by center & pt Constructs P-circle with given center passing through point 
circle by center & radius Constructs P-circle with given center and a radius specified 

by a segment 
Perp Pt to Pt intersect Constructs a line perpendicular to a point on given line 

determined by two points 

Disk

P-Disk Center

P-Disk Radius
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Illustration 
 Let’s create a triangle in the P-Disk and measure an angle.  Start with the basic Poincare 
model in a sketch. 
 
Construct a P-triangle:  Create 3 points in the interior of the P-Disk. Now select the Poincare 
segment tool from the Custom Tool > Poincare Disk folder. (Remember to show script 
view.) Click two of the three points, then the radius and finally the center of the disk. This 
creates a P-segment connecting the two selected points. On your own, construct to remaining 
two sides of the triangle.  You should have something like the triangle below. 
 
 
 
 
 
 
 
To measure an angle, select the Poincare angle tool from the Custom Tool > Poincare Disk 
folder.  Notice the order of the points to be selected – the vertex of the angle is the middle 
point. Click the three vertices, then the disk radius and disk center. A textbox with the angle 
measure will appear in the upper left corner of the sketch. Right click the box and choose 
Properties if you want to change the default name of the angle. Repeat for the other two angles.  
Here is my result. 
 
 
 
 
 
 
 
 
 
 
 
 
 
We conclude this section with a description of the tools available for the half-plane model. 
 
To work with the half-plane model first construct two points, P1 and P2 (from left to right) and 
an Euclidean line through them. The model will consist of the points above this line. Here is a 
list of the tools with a brief description of what each does. 
 

Half-plane Line Constructs the hyperbolic line through two points 
Half-plane Segment Constructs the hyperbolic segment through two points 
Half-plane Angle Measures hyperbolic angle with second point as vertex 
Half-plane Distance Measures the hyperbolic distance between two points 

 

Disk

P-Disk Center

P-Disk Radius

HL

HM

HN

Theta = 26.0°

Theta = 8.1°

Theta = 45.5°
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Tranformations 
 
The Geometer’s SketchPad has the capability to transform objects by translations, dilations 
(scaling), reflections, and rotations.  These are found under the Transform menu.  A full 
explanation of the transformations can be found under Help > Menus. Then choose 
Transform menu. Below reflections and rotations are illustrated. 
 
To begin, construct a triangle with vertices A, B, C, two intersecting lines m and n, and the 
point H where the two lines intersect as pictured. (your labeling may be different.) 
 
 
 
 
 
 
 
 
 
 
Reflection 
We want to reflect triangle ABC about line m.  First select the line m (the axes).  Choose Mark 
Mirror from the Transform menu.  Now, select the triangle and choose Reflect from the 
Transform menu.  Congratulations! You just performed your first transformation.  Select the 
“finger” tool and identify the labels of the new triangle.  They should be A’, B’ and C’. 
 
Now reflect the new triangle A’B’C’ about the line n to get a triangle A’’B’’C’’.  You can see 
the results dynamically by moving one of the lines or the original triangle. 
 
Rotations 
Objects are rotated by a specified amount around a fixed point (the center of rotation).  We will 
need to specify both of these.  First check (and change if you so desire) the setting in the 
Preferences option of the Edit menu to see whether the unit for angle measurement is degrees 
or radians.  
 
Select H as the center of rotation and choose Mark Center from the Transform menu. We 
want to mark an angle. Select a point on line m, H, and then a point on line n.  Choose Mark 
Angle from the Transform menu.  Now, we’re ready to rotate.  Select the triangle ABC and 
choose Rotate from the Transform menu. The dialog box should confirm you wish to rotate 
an object about H by the angle you have marked.  (If you did not mark an angle, you will get a 
different dialog box which lets you enter the number of units for a rotation.)  Click “OK’ and 
you should see the results.   
 
The results of the rotation should be selected (otherwise select it). Rotate the image one more 
time by the same amount around H.  Where did the second image go?  How does it compare 
with the two reflections?  Move the lines and triangle to dynamically see if things change. 
 
Conjecture a result you think is true about reflections and rotations. 
 
Here is a quick introduction to dilations and translations. 
 

m

n
A

B

C
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Dilations 
To dilate an object we need a center of the dilation (like an origin) and a scaling factor.  The 
center is easy. Select a point and choose Mark Center from the Transform menu as you did 
with a rotation.  The scale can be set in either of two ways.   

Numerically: In this case select the object to be dilated and choose Dilation from the 
Transform menu.  Then enter the numerical scaling factor in the dialog box and click 
“OK”. 
 
Ratio of segments: In this case first select two segments and choose Mark Ratio from 
the Transform menu.  Then select the object to be dilated, choose Dilation from the 
Transform menu, and click “OK” to using the marked center and ratio. 

 
 
Translations 
A translation is specified by either giving a vector or by specifying the direction and magnitude 
of the translation.  Both options are available here. 

Vector:  Select the points that determine the tail and the head of the vector (in that 
order). Then choose Mark Vector from the Transform menu.  Now select the object 
to be translated and choose Translate from the Transform menu. In the dialog box 
make sure “Marked” is selected and click “Translate”. 
Direction and Magnitude:  Select the object to be translated and choose Translate from 
the Transform menu. In the dialog box there is a choice of Rectangular (specify the x 
and y distances to be translated) or Polar (specify the direction (0° is the positive x-
direction) and the magnitude of the translation).  Fill in your choices, then click 
“Translate”. 

 
Note: After constructing a series of transformations you may want to have a single mapping 
that performs the composition.  This single mapping can be defined as a Custom Tool (see 
Section 3).  
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JavaSketchpad Documents 
 
This section provides instructions for how to convert an interactive sketch constructed with 
Geometer’s SketchPad (version 4) into a Java applet for use via a browser. The resulting 
HTML file can be manipulated either over the web or locally from a disk.  
 
Step 1. Organizing files 
First decide where the HTML file and Java applets are to be placed. This may be in a folder on 
a web server (if to be accessed from the internet) or in a folder on a disk that can be given to 
students or placed on a stand-alone computer. Give the folder a name like My JavaSketch 
files. Now, into this folder copy the folder jsp that contains the applet class files. The jsp 
folder can be found where the Sketchpad files were installed, usually in the Sketchpad folder 
under Program Files on the C: drive. After copying the jsp folder into My JavaSketch files 
you are ready to begin. 
 
Step 2. Create an interactive sketch 
By now you have done lots of these. Save the sketch in the regular way so it can be used again. 
 
Step 3. Saving the sketch as a HTML file 
From the File menu choose Save As to bring up the Save As dialog box. In the “Save in:” field 
navigate to the folder My JavaSketch files so the HTML file will be saved in the same 
location as the jsp folder. Now, open the “Save as type:” box (the bottom one) and select the 
type: HTML/JavaSketchpad Document (*.htm). Now in the “File name:” box specify a 
name, e.g., sketch1.  The extension should automatically be “.htm”.  If not, make sure the 
proper type is selected. Click the Save button and that’s it. 
 
Step 4. Test HTML file 
You should be asked if you want to view the Java applet in the HTML file after you save. If 
not, exit GSP and go to the My JavaSketch files folder and double click the HTML file just 
created. Test to make sure it works. 
 
Step 5. Cleaning up the HTML file 
The JavaSketchpad applet created in the HTML file can be place on another web page or the 
created page can be edited to add additional information. The essential html code for the applet 
is 

<APPLET CODE="GSP.class"  ARCHIVE="jsp4.jar" CODEBASE="jsp" WIDTH=339 HEIGHT=279 
ALIGN=CENTER> 

This is the code that makes construction work. 
</APPLET> 

 
The applet tag can be copied to another page. Be sure the new page is located in the same place 
that the jsp folder is located. The CODEBASE specifies where a browser looks for the class 
files that make the applet work.  The html code outside the <APPLET …>…</APPLET> tag can be 
edited however you want it. 
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"An exploration of Brahmagupta's formula using The Geometer's Skrtchpad", Mary Beth 
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Michael Stone, The Mathematics teacher, v. 87, no. 8, November 1994, pp. 590-594. 
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"The Euler Line and Nine-Point-Circle Theorems", Frank Eccles, The Mathematics Teacher, 
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"The Angles of a Star", Alan Lipp, The Mathematics Teacher, v.93, no.6, September 2000, pp. 
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October 2000, pp. 578-580. 
 
"A Triangle Divided: Investigating Equal Areas", Daniel Scher, The Mathematics Teacher, 
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